黑月版
.程序集 程序集1
 .程序集变量 对话框, 对话框类
 .程序集变量 _编辑框1, 编辑框类
 .程序集变量 _按钮1, 按钮类

.子程序 _启动子程序, 整数型
    对话框.载入 (, 1000, & 对话框创建完毕)
    返回
(0)

.子程序 对话框创建完毕
 .参数 hwnd, 整数型

    _编辑框1.绑定 (hwnd, 1001)
    _按钮1.绑定 (hwnd, 1002)
    _按钮1.事件_被单击 (& 按钮被单击)

.子程序 按钮被单击
    处理返回
(查询 (到小写 (删首尾空 (_编辑框1.内容 ()))))

.子程序 处理返回
 .参数 back, 文本型
 .局部变量 位置一
 .局部变量 位置二
 .局部变量 temp, 文本型
 .局部变量 ip, 文本型
 .局部变量 location, 文本型
 .局部变量 临时数组, 文本型, , "0"

    位置一 = 寻找文本 (back,“< p >”, , )
    位置二 = 寻找文本 (back,“< /p >”, , )
    temp = 取文本中间 (back, 位置一 + 3, 位置二 - 位置一 - 4)
    位置一 = 寻找文本 (temp,“< code >”, , )
    位置二 = 寻找文本 (temp,“< /code >”, , )
    ip = 取文本中间 (temp, 位置一 + 6, 位置二 - 位置一 - 6)
    location = 取文本右边 (temp, 取文本长度 (temp) - 倒找文本 (temp,“自”, , ) - 3)
    临时数组 = 分割文本 (location,“ ”, )
    信息框api (ip + 临时数组 [ 1 ], , )

.子程序 查询, 文本型
 .参数 ipaddress, 文本型

    返回 (到文本 (HTTP读文件 (“http://www.ip.cn/getip.php?action=queryip& ip_url=” + ipaddress +“& from=web HTTP/1.1”)))


易语言打造www.ip.cn查询小软件
效果图

昨晚上写的时候不知道为什么
http://www.ip.cn/getip.php?action=queryip& ip_url=” + ipaddress +“& from=web HTTP/1.1”
如果ipaddress为网址的话,会返回错误信息。
 
然后还是不知道为什么昨晚在虚拟机里ping 百度首页,会返回显示在浙江绍兴(dns服务器地址)

最后还是不知道为什么,今天一切就都正常了易语言打造www.ip.cn查询小软件易语言打造www.ip.cn查询小软件易语言打造www.ip.cn查询小软件易语言打造www.ip.cn查询小软件


最后的最后,放个成果
易语言打造www.ip.cn查询小软件
界面

易语言打造www.ip.cn查询小软件
这是静态编译的
易语言打造www.ip.cn查询小软件
这是黑月+UPX压缩后的结果,费尽千辛万苦只能搞成这么小了。